www.linuxonlinehelp.de Nonprofit Linux PC & Server Support by Thomas Sternasky Germany » Linux Fehler-Bugs

Category: Linux Fehler-Bugs

Ubuntu 13.04 Bug: gvfs smb Nautilus freeze hangs on copy files from a Samba Share

Kommentare Kommentare deaktiviert
Von , Montag, Juli 15, 2013

gvfs-smb Bug #1075923 (seen on Debian+Ubuntu+Centos..more..)

Workaround:

downgrade gvfs-* to Version 1.12 of 12.10 with:
- add /etc/apt/sources.list
deb http://de.archive.ubuntu.com/ubuntu precise main
deb-src http://de.archive.ubuntu.com/ubuntu precise main

- run: sudo apt-get update
- install synaptic: sudo apt-get install synaptic
- run synaptic: sudo synaptic
- remove all gvfs-* nautilus with synaptics (REALLY CHECK ALL! see “dpkg -l | grep gvfs”)
- search gvfs-*, select, press CTRL+E (Force Menu)
- select: gvfs-* Versions 1.12
- install by run install button
- search and install nautilus again..

Voila…Test Nautilus copy 1TB Files without freeze

Debian Bug: Slow user switching at Console (su, sudo, slow ssh logon, slow PC,IPv6 Problems)

Kommentare Kommentare deaktiviert
Von , Mittwoch, Oktober 10, 2012

Problem: On a Debian Squeeze/Ubuntu with default setup the interaction can be very slow at your Home Network. SSH Logon seems to hang seconds, Browser startup and www browsing could be slow or offer waits

Background: IPv6 was implemented on newer OS, but never used at Local Networks (IPv4) cause there are no IPv6 Nameservers!!!

Solution:

  • edit with #sudo nano /etc/hosts and comment out IPv6 with #


# The following lines are desirable for IPv6 capable hosts
#::1 ip6-localhost ip6-loopback
#fe00::0 ip6-localnet
#ff00::0 ip6-mcastprefix
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters

  • then disable IPv6 on boot for the services and programs with #sudo nano /etc/sysctl.conf


#disable ipv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

  • NOW reboot the PC and test all programs like ssh login, shell login, sudo switch, Browser..for speed should be faster..
  • THIS is SAME on other OS like Windows Vista, 7, 8.. same Problems!!

Debian Linux Wheezy: Partitioning 3TB Hard Drives with GPT Table (fdisk show 2TB max.)

Kommentare Kommentare deaktiviert
Von , Mittwoch, Oktober 3, 2012

Problem: On Debian Linux the brand new 3TB SATA Drives only seen as 2TB Drives by fdisk

Background: GPT Partition Table must be used as new technology

Solution:

  • install “gdisk” the GPT Tool for big Drives with #sudo aptitude install gdisk
  • clean the new Drives first Table Headers with #sudo dd if=/dev/zero of=/dev/sdb count=1 bs=512
  • run now #sudo sgdisk /dev/sdb
  • Command is “sgdisk” not “gdisk” = its Paket Name
  • same on other Linux/BSD Systems on Windows use Paragon Tools
HDD Layout

HDD Layout

Ubuntu 12.04 Bug High Prio : Grub 2 grub-pc hangs on reboot timeout not working

Kommentare Kommentare deaktiviert
Von , Sonntag, Juni 10, 2012

Prio 1: Set to Prio 1 cause it prevent a remote ubuntu Server from Boot without interactive root access to the Grub 2 Boot Screen !!

Problem: If you do a release upgrade to ubuntu 12.04 use grub-pc and have a seperate /boot partition (sda1) then your server won’t boot without you pressing enter at the grub2 grub-pc menu.

Background: this is a older known bug of a header skript template.

Solution:

  1. for Servers you should remove grub2 and install grub
  2. or make changes with


sudo nano /etc/grub.d/00_header


make_timeout ()
{
cat << EOF
if [ "\${recordfail}" = 1 ]; then
set timeout=-1
else
set timeout=${2}
fi
EOF
}

change to:

make_timeout ()
{
cat << EOF
set timeout=0
EOF
}

recreate /boot/grub/grub.cfg with:

sudo grub-mkconfig
sudo update-grub

..now cross fingers and reboot the PC/Server..hope it will boot up!

REMARK: MY published security tip against init destroy by crashes setting at /etc/fstab to mount /boot partition readonly should NOT used on ubuntu 12.04 cause a file named grub-env is updated on every boot for a function named failover stamp, which prevent the timeout to auto boot a crashed server (lost power), cause the root must be manual touch the grub to boot a server to repair mode called “single mode” or “rescue mode”.

Gnome 3 Bug: gnome-terminal disabled F10 open context menu

Kommentare Kommentare deaktiviert
Von , Sonntag, Mai 6, 2012

Problem: If you use Debian or Ubuntu with Gnome 3 Desktop or Gnome Classic 3 Desktop and you want disable F10 for the use of Midnight Commander the Context Menu of the mouse opens automaticly.

Solution:

  1. run as User # mkdir ~/.config/gtk-3.0/
  2. then #nano gtk.css
  3. insert

    @binding-set NoKeyboardNavigation {
    unbind "F10"
    }

    * {
    gtk-key-bindings: NoKeyboardNavigation
    }

  4. relogin as User, for systemwide config copy “/.config/gtk-3.0/gtk.css” into /etc/skel folder

Debian Linux: Squeeze ATI Mobility M7 xorg.conf Thinkpad T30 Performance

Kommentare Kommentare deaktiviert
Von , Mittwoch, Februar 15, 2012

Problem: Squeeze fglrx does not support older ATI Chips
(If i view Flashvideos the CPU usage hold at 100% after change 25-30% usage !)
Solution: sudo nano /etc/X11/xorg.conf and paste

Section "ServerLayout"
  Identifier     "X.org Configured"
  Screen      0  "Screen0" 0 0
  InputDevice    "Mouse0" "CorePointer"
  InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
  ModulePath   "/usr/lib/xorg/modules"
  FontPath     "/usr/share/fonts/X11/misc"
  FontPath     "/usr/share/fonts/X11/cyrillic"
  FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/Type1"
  FontPath     "/usr/share/fonts/X11/100dpi"
  FontPath     "/usr/share/fonts/X11/75dpi"
  FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
  FontPath     "built-ins"
EndSection

Section "Module"
  Load  "extmod"
  Load  "glx"
  Load  "dri"
  Load  "dbe"
  Load  "record"
  Load  "dri2"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "kbd"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "auto"
  Option      "Device" "/dev/input/mice"
  Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Device"
  Identifier "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
  Driver "radeon"
  BusID "PCI:1:0:0"
  Option "AGPMode" "4"
  Option "XAANoOffscreenPixmaps"
  Option "AGPFastWrite" "true"
  Option "EnablePageFlip" "on"
EndSection

Section "Screen"
  Identifier "Screen0"
  Device "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
  Monitor "Monitor0"
  DefaultDepth 16
  SubSection "Display"
    Depth 16
    Modes "1024x768"
  EndSubSection
EndSection

Section "DRI"
  Mode 0666
EndSection

Debian Linux: Squeeze ATI Fire GL T2 Thinkpad R50p xorg.conf with 3D

Kommentare Kommentare deaktiviert
Von , Mittwoch, Februar 15, 2012

Problem: Squeeze Kernel does not Support older ATI chips with fglrx

Solution:  edit  with sudo nano /etc/X11/xorg.conf  and paste

(Remark: use Driver “ati” for 3D , use “radeon” for sometimes faster flashvideos)

Section "ServerLayout"
  Identifier     "X.org Configured"
  Screen      0  "Screen0" 0 0
  InputDevice    "Mouse0" "CorePointer"
  InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
  ModulePath   "/usr/lib/xorg/modules"
  FontPath     "/usr/share/fonts/X11/misc"
  FontPath     "/usr/share/fonts/X11/cyrillic"
  FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/Type1"
  FontPath     "/usr/share/fonts/X11/100dpi"
  FontPath     "/usr/share/fonts/X11/75dpi"
  FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
  FontPath     "built-ins"
EndSection

Section "Module"
  Load  "extmod"
  Load  "dri2"
  Load  "record"
  Load  "dbe"
  Load  "glx"
  Load  "dri"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "kbd"
  Option      "xkblayout" "de"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "auto"
  Option      "Device" "/dev/input/mice"
  Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Device"
        VendorName  "ATI Technologies Inc"
        BoardName   "M10 NT [FireGL Mobility T2]"
        BusID       "PCI:1:0:0"
        Option      "AGPMode" "4"
        Option      "EnablePageFlip" "True"
        Identifier      "ATI FireGL T2"
        Driver          "ati"
        VideoRam        131072
        Option          "UseFBDev"      "off"
        Option          "MergedFB"      "off"
        Option          "AGPMode"       "4"
        Option          "AccelDFS"      "on"
        Option          "DynamicClocks" "on"
        Option          "XAANoOffscreenPixmaps" "true"
EndSection

Section "Screen"
  Identifier "Screen0"
  Device     "Card0"
  Monitor    "Monitor0"
  SubSection "Display"
    Viewport   0 0
    Depth     1
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     4
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     8
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     15
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     16
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     24
  EndSubSection
EndSection

Debian Wheezy: linux/videodev.h no such file or directory mjpg-streamer compile error

Kommentare Kommentare deaktiviert
Von , Mittwoch, September 21, 2011

Problem: On Debian Wheezy Kernel 3.0 the compile of older video4linux (like mjpg-streamer)  scripts fails with message, cause linux/videodev.h was replaced by linux/videodev2.h

Error Message at "make" compile: ...linux/videodev.h : no such file or directory

Solution:

  1. download last sources of mjpg-streamer-experimental and extract to /usr/src/mjpg-streamer/
  2. sudo cd /usr/src/mjpg-streamer/  and sudo make clean all, if fails then
  3. sudo apt-cache search videodev.h shows libvideo-ivtv-perl
  4. sudo aptitude install libvideo-ivtv-perl
  5. try recompile if fails..
  6. updatedb && locate videodev.h, shows not found ??  then..
  7. updatedb && locate videodev2.h, videodev2.h is found? then
  8. cp /usr/include/linux/videodev2.h  /usr/include/linux/videodev.h
  9. try recompile, if libjpeg errors appear then install
  10. sudo aptitude install libjpeg62-dev, the development libraries
  11. recompile..now the webcam should work..

Linux Bug: Disable Framebuffer Nvidia free Driver Nouveau for hanging xserver-xorg (for Servers)

Kommentare Kommentare deaktiviert
Von , Freitag, März 18, 2011

Problem: Nouveau the free Version of the Nvidia Display Driver crash if you switch to Console or kill the xserver-xorg.Its enabled by default inside the KERNEL!! this WAS NOT DEFAULT at last DECADES!! (DEBIAN 3.0-5.0 never used it!, cause bugs and hanging Servers)

Solution:

echo 'blacklist nouveau' > /etc/modprobe.d/blacklist-nouveau.conf

then edit with $sudo nano /etc/default/grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="noquiet nouveau.nomodeset=0" #on Ubuntu set "nomodeset noplymouth"
...

update grub Loader with

sudo update-grub2

REMARK: THIS MUST BE USED AT SERVERS FOR STABILITY!! REMOVE / BLACKLIST ALL UNEEDED DRIVER MODULES LIKE SOUND!
(DISABLE ALWAYS UNNEEDED CHIPS AT YOUR BIOS AGAINST PROBLEMS AND ENERGY COSTS)

Linux Bug: SATA failed command: WRITE FPDMA QUEUED ata3.00 ncq freeze hang

Kommentare Kommentare deaktiviert
Von , Freitag, März 18, 2011

Problem: If you copy or install Files from Disk to Disk somtimes the fresh installed Debian Ubuntu Linux in Textmode (server minimal setup) current kernel freezes or lost connect to the Disks. Take a CLOSER LOOK the Error often affects ALL DISKS !! If only one Disk  affected replace the Drive to SATA600

Hardware:  Asus M4n75TD NEW with Phenom 1090T X6 and 8GB Ram and

/dev/sda:
Model=Hitachi, FwRev=GM4OA52A, SerialNo=GEA530RF1RDDGA
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=56
BuffType=DualPortCache, BuffSize=15118kB, MaxMultSect=16, MultSect=off
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=976773168
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes:  pio0 pio1 pio2 pio3 pio4
DMA modes:  mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
AdvancedPM=yes: disabled (255) WriteCache=enabled
Drive conforms to: unknown:  ATA/ATAPI-2,3,4,5,6,7

/dev/sdb:
Model=ST3320620AS, FwRev=3.AAE, SerialNo=9QF8EZ82
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
BuffType=unknown, BuffSize=16384kB, MaxMultSect=16, MultSect=off
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=625142448
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes:  pio0 pio1 pio2 pio3 pio4
DMA modes:  mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
AdvancedPM=no WriteCache=enabled
Drive conforms to: Unspecified:  ATA/ATAPI-1,2,3,4,5,6,7

Errors seen on syslog:

...
Mar 17 20:31:44 phenom kernel: [   45.026839] ata1.00: status: { DRDY }
Mar 17 20:31:44 phenom kernel: [   45.026887] ata1.00: failed command: WRITE FPDMA QUEUED
Mar 17 20:31:44 phenom kernel: [   45.026934] ata1.00: cmd 61/28:20:18:9c:4c/00:00:1d:00:00/40 tag 4 ncq 20480 out
Mar 17 20:31:44 phenom kernel: [   45.027042] ata1.00: status: { DRDY }
Mar 17 20:31:44 phenom kernel: [   45.027087] ata1.00: failed command: WRITE FPDMA QUEUED
Mar 17 20:31:44 phenom kernel: [   45.027134] ata1.00: cmd 61/18:28:d8:d0:4c/00:00:1d:00:00/40 tag 5 ncq 12288 out

Solution Steps:

  • Check SATA Cable and reboot and check
  • Replug all Cables and reboot and check
  • Change the SATA PORTS! Sata1 to Sata2 for Disk0
  • Change the SATA PORTS! Sata3 to Sata4 for Disk1
  • Often the Harddisks are NOT damaged!!
  • Looks like a failed Hardware Control by the SATA 600 Controllers with SATA 300/150
  • take new SATA 600 Drives and recheck

Remark: Windows Systems have same Error without Logs, the Systems seems to hang for seconds!

 

Debian Squeeze Bug: udevd-work: kernel-provided name ‘uinput’ and NAME= ‘input/uinput’ disagree, please use SYMLINK+

Von , Sonntag, Dezember 19, 2010

Problem: After a fresh Setup and first Reboot of Squeeze the Boot Message
udevd-work[77]: kernel-provided name 'uinput' and NAME= 'input/uinput' disagree, please use SYMLINK+= or change the kernel to provide the proper name
appears
Solution:
edit:
sudo nano /lib/udev/rules.d/50-udev-default.rules

and change,
KERNEL=="uinput", NAME="input/%k"
to:
KERNEL=="uinput", SYMLINK+="input/%k"

Debian Ubuntu: Openbox Lxpanel Bug “Abmeldebefehl ist nicht definiert” “Logout command is not set”

Von , Mittwoch, November 17, 2010

Problem: If you install Openbox with lxpanel instead of LXDE and the User Profile is created after first logon, lxpanel config files are not created

lxpanel-logout-openbox-bug

lxpanel-logout-openbox-bug

Solution: Klick right with the Mouse on the lxpanel-settings, go tab advanced, set exit command = openbox --exit, save and close

Ubuntu Lucid Lynx 10.04: FireGL xorg.conf Thinkpad R50p

Von , Donnerstag, September 30, 2010

Problem: By default the xorg.conf FireGL 128MB radeon driver settings are slow settings

Solution: to get a faster behavior do edit /etc/X11/xorg.conf
(Update: use Driver “ati” for 3D, use “radeon” for better flashvideos)
# sudo nano /etc/X11/xorg.conf
and change radeon area to:

Section "Device"
VendorName "ATI Technologies Inc"
BoardName "M10 NT [FireGL Mobility T2]"
BusID "PCI:1:0:0"
Option "AGPMode" "4"
Option "EnablePageFlip" "True"
Identifier "ATI FireGL T2"
Driver "radeon"
VideoRam 131072
Option "UseFBDev" "off"
Option "MergedFB" "off"
Option "AGPMode" "4"
Option "AccelDFS" "on"
Option "DynamicClocks" "on"
Option "XAANoOffscreenPixmaps" "true"
EndSection

SME Server USB Disk Stick mount Problem at SME Server Backup Console

Von , Donnerstag, September 23, 2010

Problem:
On SME Server the HAL Daemon often not recognize a USB Stick or Disk
which you can use for “Console” Backup Program.

Solution:
- Create a Script with #nano /root/backup.sh
- insert:

  • service haldaemon restart
  • service messagebus restart
  • console
  • exit

This restart the HAL Environment before Console (SSH-Admin-Tool)is opened.

To prevent Users to write on the Shares if you run the Backup you can add:

  • service haldaemon restart
  • service messagebus restart
  • service smb stop
  • console
  • service smb start
  • exit

This will stop Samba-Windows Shares! and prevent File-Access-Lockwaits!

Xsession: warning XRDB command not found: X resources not merged

Von , Donnerstag, September 23, 2010

System: Debian Lenny

Error: Xsession: warning XRDB command not found: X resources not merged

XDM Login Manager grey logo (Black/White not colored)

Solution: Install Package “xbase-clients”

#sudo aptitude install xbase-clients

and restart XServer..


Webcam Bad Hersfeld Erlebnisreisen Steinberger Busreisen Webcam Eiterfeld Franz Raab Schauspieler Bad Hersfeld Genealogy Family Sternasky Research